Seamless restart / zero-downtime deploy for Go servers
☆125Sep 10, 2024Updated 2 years ago
Alternatives and similar repositories for seamless
Users that are interested in seamless are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Go task package☆15May 16, 2024Updated 2 years ago
- string interning library for lots of strings☆38Mar 18, 2021Updated 5 years ago
- Lightweight package containing some ORM-like features and helpers for sqlite databases.☆15Jan 30, 2023Updated 3 years ago
- A tiny job scheduler☆18Aug 23, 2026Updated 2 months ago
- A very fast arena allocator for Go☆35Oct 12, 2026Updated 2 weeks ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- ☆11Sep 19, 2024Updated 2 years ago
- Format your Golang structured logs (slog) using the JSON v2 library, with optional single-line pretty-printing☆13Sep 2, 2026Updated last month
- Toolkit for dealing with wasm (webassembly), including an strace like tool.☆18Sep 22, 2025Updated last year
- Show progress of concurrent tasks in your terminal – a minimalistic Go library with a lock-free design☆21Dec 20, 2024Updated last year
- Go and PostgreSQL job queue blueprint☆51Jan 27, 2023Updated 3 years ago
- A lisp implementation in pure GO.☆11Nov 23, 2017Updated 8 years ago
- Linter for errors.Is and errors.As☆45Dec 3, 2019Updated 6 years ago
- A Rust library and CLI tool for evaluating whether two or more sets of measurements are statistically different.☆14Jan 16, 2023Updated 3 years ago
- A tool for embedding Go code in a Go binary using go-bindata.☆13Aug 22, 2015Updated 11 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- ☆15May 23, 2026Updated 5 months ago
- cgosymbolizer teaches the Go runtime to include cgo frames in backtraces☆31Feb 5, 2022Updated 4 years ago
- A Go package for myriad array operations using wavelet trees☆19Feb 28, 2016Updated 10 years ago
- Murmur3 hash in Go☆13Dec 15, 2017Updated 8 years ago
- An one-time password generation library written in Go, implementing HOTP (RFC-4226) and TOTP (RFC-6238).☆12Sep 23, 2012Updated 14 years ago
- A set of packages for reuse within Heroku Go applications☆55Oct 21, 2026Updated last week
- Orion is a globally distributed SQL Database for storing control plane metadata of SAAS applications.☆16Oct 9, 2026Updated 3 weeks ago
- Moved to https://codeberg.org/ilius/chunk32☆12Nov 15, 2025Updated 11 months ago
- Exposes batch message receives (recvmmsg)☆14Sep 11, 2026Updated last month
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- create low memory key/value objects in Go☆22Apr 18, 2017Updated 9 years ago
- Go package providing efficient time management primitives.☆18Jun 26, 2023Updated 3 years ago
- More aggressive `go vet`☆88Feb 20, 2018Updated 8 years ago
- Test-driven data pipelines in pure Go☆11Jul 16, 2020Updated 6 years ago
- Go translation of MetroHash☆119Oct 8, 2026Updated 3 weeks ago
- https://anonscm.debian.org/cgit/pkg-go/packages/golang-dbus.git☆15Nov 18, 2015Updated 10 years ago
- JavaScript interpreter written in Go☆18Aug 16, 2015Updated 11 years ago
- Raft in-memory backend implementation with persistence☆83Aug 30, 2020Updated 6 years ago
- String deduplication package for Go☆19Jan 10, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- 3D graphics engine written in Go that runs in the terminal☆10Feb 23, 2020Updated 6 years ago
- Simple, idiomatic and fast 161 loc http router for golang☆133Sep 13, 2018Updated 8 years ago
- RFC8391: XMSS: eXtended Merkle Signature Scheme, a post-quantum signature scheme☆13Jun 12, 2019Updated 7 years ago
- Go implementation of bcrypt_pbkdf(3) from OpenBSD☆15Jun 27, 2026Updated 4 months ago
- Annotate a string line with arrows leading to a description.☆20Sep 30, 2026Updated last month
- [WIP] HIP(Host Identity Protocol) implementation in pure Golang.☆13Mar 28, 2023Updated 3 years ago
- Go framework for integration testing with Virtual machines (e.g. QEMU)☆117Aug 21, 2026Updated 2 months ago