A pure Go library for interacting with USB HID devices, supporting Linux, macOS, and Windows.
β31Sep 1, 2026Updated 2 months ago
Alternatives and similar repositories for usbhid
Users that are interested in usbhid are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- π§ Implemented Keys, Algorithms (RFC9053), COSE (RFC9052) and CWT (RFC8392) in Go.β24Sep 1, 2026Updated 2 months ago
- Unix userland implemented in pure Go, texutils, pipes, exec handlers, shell colon parsing.β20Feb 15, 2023Updated 3 years ago
- A pure-Go implementation of fakeroot using Linux user namespaces.β19Oct 24, 2023Updated 3 years ago
- pure golang crypt(3) implementationβ22Jul 21, 2026Updated 3 months ago
- T is a work-in-progress text editor inspired by the Acme editor from Plan9.β10Feb 17, 2019Updated 7 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer β’ AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Contents from Solaris 8 Source Foundationβ12Oct 11, 2021Updated 5 years ago
- Draw with codes, for kids and coders~β11Updated this week
- Nim Unstructured/Useless Text Editorβ12Nov 18, 2024Updated last year
- glaucus screenshotsβ15Apr 10, 2026Updated 6 months ago
- Pure Go Wayland protocol implementation.β10Feb 16, 2026Updated 8 months ago
- A secure utmp/wtmp implementationβ20Jul 14, 2026Updated 3 months ago
- Library to ease porting userland OpenBSD code to Serenityβ16Mar 14, 2020Updated 6 years ago
- A stream abstraction designed for use with nomβ17Feb 3, 2026Updated 9 months ago
- Handy POSIX(mostly) scripts I made for personal use.β10Jun 23, 2024Updated 2 years ago
- Simple, predictable pricing with DigitalOcean hosting β’ AdAlways know what you'll pay with monthly caps and flat pricing. Enterprise-grade infrastructure trusted by 600k+ customers.
- Pure Go UEFI library for Linux and Windowsβ19Jan 14, 2025Updated last year
- Horizon libcβ12Nov 10, 2025Updated 11 months ago
- Quake-style colour formatting for Unix terminalsβ14Dec 2, 2023Updated 2 years ago
- Static generator for Go module vanity URLs.β14Jan 20, 2025Updated last year
- Open URLs and manage SSH port forwards from remote development environmentsβ12Oct 23, 2026Updated 2 weeks ago
- ..β14Mar 2, 2026Updated 8 months ago
- A PEG package/framework for Goβ13Jul 2, 2025Updated last year
- Minix gettyβ14Sep 5, 2017Updated 9 years ago
- glaucus core packagesβ17Updated this week
- 1-Click AI Models by DigitalOcean Gradient β’ AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- A collection of tools written or formerly managed by JΓΆrg Schilling (mirror)β15Apr 5, 2026Updated 7 months ago
- The Solaris 1.1.2 (SunOS 4.1.4) source code.β17Sep 29, 2022Updated 4 years ago
- Portable TUI Gopher client written in C89 for POSIX systems.β20Aug 31, 2025Updated last year
- An AppImage implementation made in shell scriptβ17Jun 13, 2024Updated 2 years ago
- Concourse's ATC for Nomadβ11Mar 8, 2018Updated 8 years ago
- Detect which compiler and compiler version a Linux executable (in the ELF format) was compiled withβ31Jan 15, 2024Updated 2 years ago
- Torrent storage with multiple backends and GRPC accessβ14Oct 28, 2026Updated last week
- Git command implemented in pure Goβ13Jul 20, 2026Updated 3 months ago
- fast parallel file copy for Plan 9β15Nov 2, 2023Updated 3 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI β’ AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- oasis, but with kiss aswellβ14Updated this week
- chroot environments, done in a more elegant wayβ12Sep 28, 2026Updated last month
- Gemini plugin for Dillo written in shell scriptβ18Sep 2, 2025Updated last year
- A pure Haskell implementation of Plan9's mkβ16Jan 11, 2016Updated 10 years ago
- Retro UNIX v1 (8086 port/derivation of Original UNIX v1 for PDP-11) and Retro UNIX 386 v1.? OS projectβ21Oct 18, 2024Updated 2 years ago
- Pure Go bsdiff and bspatch libraries and CLI tools.β13Feb 5, 2025Updated last year
- Experimentation with software back-porting to NEXTSTEPβ16Oct 27, 2024Updated 2 years ago