MASQUE: Proxying UDP in HTTP/3, RFC 9298
☆263Nov 3, 2026Updated this week
Alternatives and similar repositories for masque-go
Users that are interested in masque-go are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Proxying IP in HTTP/3, RFC 9484☆82Updated this week
- An IETF MASQUE implementation in Go☆75Aug 7, 2024Updated 2 years ago
- Open-source reimplementation of the Cloudflare WARP client's MASQUE protocol.☆1,525Jul 20, 2026Updated 3 months ago
- Low-level access to the QUIC Initial Packet for mimicry purposes, hard fork of quic-go.☆79Aug 4, 2026Updated 3 months ago
- WebTransport implementation based on quic-go (https://datatracker.ietf.org/doc/draft-ietf-webtrans-http3/)☆517Updated this week
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- A VPN implementation based on the MASQUE(CONNECT-IP) protocol☆58May 29, 2025Updated last year
- IP Proxying Support for HTTP☆10Oct 19, 2023Updated 3 years ago
- A proxy protocol implementation lib.☆18Apr 16, 2024Updated 2 years ago
- Simple transparent proxy library☆242Updated this week
- ☆21Oct 26, 2026Updated last week
- ☆13Sep 2, 2024Updated 2 years ago
- A 0-RTT QUIC Proxy with SNI camouflage☆276Updated this week
- QUIC connections natively over Yggdrasil☆23Oct 24, 2026Updated 2 weeks ago
- a (minimal) QPACK (RFC 9204) implementation in Go☆47Updated this week
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- a flexible proxy framework written in rust☆48Mar 13, 2025Updated last year
- Some confusing protocol☆29Oct 22, 2026Updated 2 weeks ago
- Tunnel (TUN) interface for SOCKS and HTTP proxies☆1,450Oct 31, 2026Updated last week
- A very simple QUIC server that reverse proxies requests to you existing web server.☆11Jul 25, 2024Updated 2 years ago
- A probe resistant proxy☆111Sep 1, 2021Updated 5 years ago
- A raw tunnel sending packets through faketcp☆29Sep 7, 2026Updated 2 months ago
- ☆18Updated this week
- A decently fast, native tunnel using Cloudflare WARP and its MASQUE-based protocol for Linux. Built on top of Cloudflare's quiche library…☆38Mar 4, 2026Updated 8 months ago
- Delicately-TUICed 0-RTT proxy protocol☆3,289May 15, 2025Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Mirror only. Official repository is at https://git.zx2c4.com/wireguard-go☆4,506Oct 24, 2026Updated 2 weeks ago
- proxy core module for bepass, supports socks5/socks5h full UDP/TCP, IPv4, IPv6. supports socks4/a, http and https-connect proxy☆50Feb 25, 2024Updated 2 years ago
- IETF drafts for the MASQUE protocol☆32Aug 27, 2026Updated 2 months ago
- Fork of the Go standard TLS library, providing low-level access to the ClientHello for mimicry purposes.☆2,633Updated this week
- Safe, fast, small TCP/UDP-over-QUIC tunnel written in Rust☆98Updated this week
- Simple UDP Tunnel☆22Feb 28, 2026Updated 8 months ago
- A third-party SOCKS5 proxy for Cloudflare WARP via the MASQUE/WireGuard protocol, based on usque.☆39Aug 18, 2026Updated 2 months ago
- A multi-protocol proxy server written in Rust (HTTP, SOCKS5, Vmess, Vless, Shadowsocks, Trojan, Snell, Hysteria2, TUIC v5, AnyTLS, Naivep…☆1,294Updated this week
- Legacy WireGuard kernel patch that wraps handshake packets in a QUIC-like header over UDP/443.☆48Oct 29, 2026Updated last week
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- ☆26Sep 29, 2026Updated last month
- Exposes batch message receives (recvmmsg)☆14Sep 11, 2026Updated last month
- A simple Go launcher for usque that handles registration, configuration, and running a SOCKS proxy. Designed for Cloudflare MASQUE protoc…☆144Nov 1, 2025Updated last year
- TPM 2.0 TSS keyfile library☆24Sep 2, 2026Updated 2 months ago
- custom protocol network proxy☆1,745Updated this week
- Restls Protocol: A Perfect Impersonation of TLS; Restls协议: 对TLS的完美伪装☆377Nov 5, 2023Updated 3 years ago
- Multiple WireGuard Proxy☆100Nov 25, 2024Updated last year