Framework for representing, validating, querying, and manipulating generic JSON values in Swift 6. Supported are standards such as JSON Text Sequences (RFC 7464), JSON Pointer (RFC 6901), JSON Path (RFC 9535), JSON Patch (RFC 6902), JSON Merge Patch (RFC 7396), and JSON Schema.
☆187Oct 25, 2026Updated last week
Alternatives and similar repositories for swift-dynamicjson
Users that are interested in swift-dynamicjson are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A small, dependency-free HTTP/1.1 server framework in Swift for macOS, iOS and tvOS. Run a web server inside your app or tool: routing, J…☆14Oct 15, 2026Updated 2 weeks ago
- Swift wrapper for kqueue file system monitoring☆42Jan 5, 2026Updated 9 months ago
- 🧬 TextDiffing helps you create an AttributedString / NSAttributedString to visualize differences between texts.☆170May 16, 2026Updated 5 months ago
- Collection of Cocoa controls that look just right, offer modern Swift APIs, and nicely compose together.☆64Sep 15, 2026Updated last month
- Performant and reusable text view component (TextKit 2), with line numbers and more. UITextView / NSTextView replacement.☆1,610Oct 6, 2026Updated 3 weeks ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- A Swift library for working with JSON Schema definitions — especially for AI tool use.☆57Aug 28, 2025Updated last year
- 🫙🌶️ Spices makes it straightforward to create in-app debug menus by generating native UI from Swift.☆408Aug 24, 2026Updated 2 months ago
- It's like Git for your Swift data types.☆484Mar 4, 2026Updated 7 months ago
- Swift Concurrency wrapper for monitoring file system events using FSEvents☆47Sep 5, 2026Updated last month
- Swift APIs for SQLite: Type-safe down to the schema. Very, very, fast. Dependency free.☆517Jan 30, 2026Updated 9 months ago
- A collection of TextRenderer samples for SwiftUI.☆341Apr 3, 2026Updated 6 months ago
- A Swift library for efficient, flexible content-based text styling☆394Aug 27, 2026Updated 2 months ago
- Practical solutions to problems with Swift Concurrency☆1,324Aug 22, 2026Updated 2 months ago
- Abstractions for working with TextKit 1 and 2☆66Sep 21, 2026Updated last month
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- A queue for Swift concurrency☆439Aug 22, 2026Updated 2 months ago
- A native Swift implementation of glob match patterns.☆75Oct 14, 2026Updated 2 weeks ago
- AppKit and UIKit without conditional compilation☆85Apr 28, 2026Updated 6 months ago
- ☆200Nov 24, 2023Updated 2 years ago
- A new URL type for Swift☆385Oct 12, 2026Updated 3 weeks ago
- 💟 SFSymbols gives you a ready-to-use symbol picker for SwiftUI and an async API for reading the system SF Symbols catalog.☆92Aug 15, 2026Updated 2 months ago
- Swift library for working with ranges types: NSRange, IndexSet, and String.Index☆86Aug 23, 2026Updated 2 months ago
- Subprocess is a cross-platform package for spawning processes in Swift.☆742Oct 23, 2026Updated last week
- Swift language bindings presenting Automerge☆331Oct 9, 2026Updated 3 weeks ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Concurrency support for NSXPCConnection☆64Updated this week
- Add Night Mode appearance, a black and red color scheme designed to minimize sleep deprivation.☆14Aug 24, 2025Updated last year
- A simple, lightweight replacement for UserDefaults that makes access a little more straightforward (plus some niceties!)☆493Nov 24, 2025Updated 11 months ago
- A fast, lightweight replacement for SwiftData, powered by SQL and supporting CloudKit synchronization.☆1,955Updated this week
- libSQL bindings for Swift☆53Jul 29, 2025Updated last year
- Minimal type-safe context propagation container☆205Oct 26, 2026Updated last week
- AsyncSequence Data transforms☆27Apr 23, 2024Updated 2 years ago
- A lightweight, spec-compliant Server-Sent Events (SSE) client for Swift with AsyncSequence support.☆126Updated this week
- Custom SwiftUI fonts capabilities and multi-platform font bridging.☆38Jul 25, 2026Updated 3 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- File system operations with a typed File value type, atomic writes, and directory traversal for Swift.☆23Updated this week
- API package for reading configuration.☆816Updated this week
- Utilities for transitioning to Swift Concurrency☆175Aug 22, 2026Updated 2 months ago
- A SwiftUI debugging toolkit for visualizing renders, layouts, and measurements.☆643Jan 29, 2026Updated 9 months ago
- Version-independent HTTP currency types for Swift☆1,034Sep 25, 2026Updated last month
- A delightfully flexible and smooth drag-and-drop Swift package for building reorderable interfaces in SwiftUI☆412Jun 17, 2025Updated last year
- A Final Cut Pro plugin to render SwiftUI views on your video☆185Nov 13, 2024Updated last year