AIFAD - Automated Induction of Functions over Algebraic Data Types
☆30Aug 11, 2026Updated 2 months ago
Alternatives and similar repositories for aifad
Users that are interested in aifad are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- Library for doing GPR (Gaussian Process Regression) in OCaml. Comes with a command line application.☆46Jun 23, 2026Updated 4 months ago
- OCaml library to work with DWARF format☆39Dec 1, 2025Updated 11 months ago
- xi-editor data structures in OCaml☆10Mar 21, 2020Updated 6 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- OCaml implementation of sets as hash tables by Jean-Christophe Filliatre☆11Feb 13, 2025Updated last year
- A tool for keeping a personal log☆16Jan 1, 2025Updated last year
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- Scheduling build jobs on regular intervals, collecting artifacts☆13Jun 15, 2026Updated 4 months ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- An implementation of the Noise Protocol, intended to be used as the base for a Wireguard implementation in OCaml.☆27Feb 11, 2020Updated 6 years ago
- A PPX syntax extension for the OCaml programming language. Adds a compile-time "if" statement.☆20Nov 20, 2020Updated 5 years ago
- Postes, Télégraphes et Téléphones☆27Apr 13, 2026Updated 6 months ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- GSL powered OCaml statistics library☆39Dec 20, 2019Updated 6 years ago
- DKIM support on e-mail☆11Oct 9, 2026Updated 3 weeks ago
- A HTTP client relying solely on the OCaml standard library, for use when bootstrapping opam☆13Jul 8, 2019Updated 7 years ago
- Elliptic Curve Diffie-Hellman on Edwards Curves (X25519, X448)☆11Oct 30, 2020Updated 6 years ago
- A distributed Continuous Integration engine for opam packages☆18Jan 30, 2022Updated 4 years ago
- OCaml syntax extension for easier manipulation of flat records☆13Aug 8, 2011Updated 15 years ago
- Cash is a Unix shell that is embedded within Objective Caml. It's a Caml implementation of (an as large as possible subset of) the API of…☆11Sep 7, 2013Updated 13 years ago
- DEPRECATED: Compile Time Reflection or Metaprogramming for OCaml☆16Apr 21, 2024Updated 2 years ago
- Implementation of several spatial indexes (R-tree, etc.)☆18Mar 7, 2023Updated 3 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- OCaml library for building clients and servers that communicate using the Redis Serialization Protocol☆13Nov 6, 2021Updated 5 years ago
- Unicode text for OCaml☆14Feb 19, 2018Updated 8 years ago
- Data visualization and plotting for OCaml☆19Nov 28, 2017Updated 8 years ago
- Finite lazy enumerators in OCaml☆21Oct 19, 2018Updated 8 years ago
- Algorithms and datastructures for phylogenetics☆14Dec 24, 2025Updated 10 months ago
- A toolkit for communicating with Emacs from OCaml☆19Jan 24, 2020Updated 6 years ago
- a distributed computing library for OCaml☆25Jan 19, 2024Updated 2 years ago
- A 'free monad' library for OCaml☆21Jun 24, 2014Updated 12 years ago
- Dynamic loader for OCaml☆14Dec 11, 2009Updated 16 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Probabilistic data structures for OCaml☆39Jan 26, 2018Updated 8 years ago
- OCaml library for resizable arrays and strings☆26Jun 23, 2026Updated 4 months ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Monad syntax using ppx extensions☆18Mar 29, 2013Updated 13 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- ☆15Aug 16, 2020Updated 6 years ago
- DEPRECATED: Abstraction over Stdlib, Lwt, and Async.☆26Jun 5, 2017Updated 9 years ago