A Rust, C and C++ library for converting between 24-bit sRGB colours and ANSI terminal 8-bit palette
☆47Feb 17, 2026Updated 8 months ago
Alternatives and similar repositories for ansi_colours
Users that are interested in ansi_colours are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- benchmark analysis and summary tool☆17Dec 15, 2021Updated 4 years ago
- nathan/pax recovered from Rust cache and Google cache☆20Dec 6, 2020Updated 5 years ago
- bat is a cat clone with wings! ...and Docker☆21Jun 18, 2019Updated 7 years ago
- More reliable path manipulation.☆72Sep 19, 2026Updated 3 weeks ago
- parser for makepkg's .SRCINFO file format☆19Jan 8, 2026Updated 9 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- ☆16May 4, 2021Updated 5 years ago
- Rust library to collect system and environment information for bug reports☆171Mar 22, 2026Updated 6 months ago
- Provide expansion of proc-macros, in a way that rustc directs you directly to the issues at hand☆22Jan 6, 2025Updated last year
- Bazel rules that support breaking a typescript codebase into small, independently-compilable libraries. "Batteries not included".☆13Dec 2, 2022Updated 3 years ago
- 100% Rust sixel encoder/decoder.☆34Sep 6, 2026Updated last month
- Gradient noise generators in C (perlin and simplex)☆12Dec 18, 2012Updated 13 years ago
- broot support function for xonsh shell☆11Sep 24, 2026Updated 3 weeks ago
- Strongly typed linear algebra library with a focus on 3D applications like games (i.e. low-dimensional vectors and matrices)☆15May 31, 2026Updated 4 months ago
- 8-bit floating-point number for Rust☆10Sep 6, 2026Updated last month
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- DeltaE is a pure-Rust implementation of the CIEDE2000 algorithm☆26Jun 15, 2021Updated 5 years ago
- An implementation of RFC6265☆31Feb 16, 2026Updated 8 months ago
- Mazes in your terminal☆45Jul 6, 2026Updated 3 months ago
- A Rust library for parsing and generating Intel HEX objects.☆25Feb 20, 2024Updated 2 years ago
- A minimalist framework for building terminal UIs in Rust☆26Sep 28, 2026Updated 2 weeks ago
- An RFC 5322, and RFC 6532 compliant email address parser.☆21Mar 1, 2026Updated 7 months ago
- Make it snow on your web site☆32Nov 5, 2024Updated last year
- Protobuf Debugging Suite☆16Oct 4, 2026Updated 2 weeks ago
- Source code for the paper Hierarchically Organized Latent Modules for Exploratory Search in Morphogenetic Systems☆14Dec 15, 2020Updated 5 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- lonely is a no_std+alloc+no TLS task executor for the Rust async/await ecosystem, focused on minimizing cross-core synchronization overhe…☆19Nov 17, 2019Updated 6 years ago
- ☆20Aug 3, 2020Updated 6 years ago
- Rust Actix-web app that demonstrates magic link authentication using the approveapi Rust crate.☆19Apr 8, 2019Updated 7 years ago
- Rust traits for nonzero generic integers☆18May 24, 2022Updated 4 years ago
- Provides Rust interface to get current memory mappings for a given process☆16Sep 7, 2022Updated 4 years ago
- Collection of celebrities scamming or influencing people by shilling crypto☆11Feb 6, 2022Updated 4 years ago
- Timezone-aware datetime library for the Rust programming language☆11May 16, 2019Updated 7 years ago
- Jupyter Kernel Protocol for rust☆14May 5, 2026Updated 5 months ago
- ☆12Sep 20, 2022Updated 4 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Sorta Text Format in UTF-8☆25Jan 9, 2024Updated 2 years ago
- Low level audio render/capture library☆40Dec 30, 2020Updated 5 years ago
- Rust crate for querying the shared-mime-info database☆18Aug 11, 2025Updated last year
- Authenticate a tarball through a signed tag in a git repository (with reproducible builds)☆17May 28, 2022Updated 4 years ago
- Rust library for checking the installed/running rustc's version.☆54Jul 25, 2024Updated 2 years ago
- GitHub action for https://github.com/release-plz/release-plz☆58Updated this week
- A CLI tool that allow you to create a temporary new Rust project using cargo with already installed dependencies☆85Sep 16, 2026Updated last month