Retrieve IP addresses for all interfaces. POSIX & Windows
☆47Jul 28, 2026Updated 3 months ago
Alternatives and similar repositories for if-addrs
Users that are interested in if-addrs are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Cross platform asynchronous network watcher☆42Mar 3, 2026Updated 8 months ago
- Retrieve system's local IP address and Network Interfaces/Adapters on FreeBSD, Linux, macOS and Windows☆145Jun 29, 2026Updated 4 months ago
- Load and resolve Cargo configuration.☆23Oct 10, 2026Updated 3 weeks ago
- A (sans-IO) implementation of the TURN (RFC5766) protocol written in Rust☆12Updated this week
- Rust library for requesting certificates from an ACME provider.☆15Oct 27, 2026Updated last week
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Rust library for parsing or writing CEA-708 closed captions☆12Oct 14, 2026Updated 2 weeks ago
- A flexible byte pool.☆19Apr 15, 2023Updated 3 years ago
- Conversion to/from binary for arbitrary types. With no_std and no_alloc support.☆34Oct 5, 2026Updated 3 weeks ago
- Chinese word segmentation Telegram bot☆13Jul 12, 2020Updated 6 years ago
- A Revamped Sentry Client For Rust☆11Mar 19, 2018Updated 8 years ago
- iroh QUIC connections as Libp2p Transport☆25Mar 16, 2026Updated 7 months ago
- A (sans-IO) implementation of the STUN (RFC5389/RFC8489) protocol written in Rust☆17Oct 20, 2026Updated 2 weeks ago
- Cross-platform library for network interface. Written in Rust.☆105Oct 25, 2026Updated last week
- Windows Linked Lists in idiomatic Rust (LIST_ENTRY, SINGLE_LIST_ENTRY)☆22Oct 19, 2023Updated 3 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Run pkg-config from declarative dependencies in Cargo.toml☆109Oct 22, 2026Updated last week
- ☆28Jul 10, 2025Updated last year
- Environment control for benchmarks☆14Feb 10, 2025Updated last year
- Send file descriptors over unix sockets in Rust☆29Sep 26, 2026Updated last month
- LLVM Bitcode parser in Rust☆26Oct 3, 2026Updated last month
- A pure Rust library for cross-platform memory mapped IO, which replaces libc with rustix.☆42Jun 24, 2026Updated 4 months ago
- Cross-platform route management interface☆23Updated this week
- Bindings to Nvidia Labs's ꟻLIP image comparison and error visualization library☆23Oct 26, 2026Updated last week
- Utility to copy files over WiFi to/from mobile devices inside a terminal.☆18Mar 8, 2024Updated 2 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- An implementation of RFC6265☆31Feb 16, 2026Updated 8 months ago
- A simple, fast, intuitive parser combinator framework for Rust.☆25Nov 23, 2025Updated 11 months ago
- A simple helper to transform Markdown links to intra-doc links in Rust projects when appropriate.☆38Dec 2, 2020Updated 5 years ago
- An experimental IPC interface definition language for Hubris.☆29Oct 10, 2026Updated 3 weeks ago
- TLS 1.3 Handshake in Linux Kernel: 1. used by QUIC implementation on 'quic' branch; 2. used by NFS over TLS on 'sunrpc' branch; 3. us…☆12Dec 5, 2023Updated 2 years ago
- A standalone Go relay server for Paseo, fully compatible with the original Paseo relay protocol (v1 and v2).☆14Oct 9, 2026Updated 3 weeks ago
- sans-IO implementation of ICE (RFC8445) in Rust☆70Updated this week
- ☆11Jul 9, 2024Updated 2 years ago
- YCbCr to sRGB converter in Rust☆25Jan 19, 2026Updated 9 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Goodies for working with the xtask concept in Rust☆35Aug 1, 2024Updated 2 years ago
- RExif is a native Rust library to extract EXIF data from JPEG and TIFF images.☆33Oct 13, 2026Updated 2 weeks ago
- Rust library for mDNS based Service Discovery☆228Updated this week
- Whitepapers and document repository for makepad☆13May 6, 2022Updated 4 years ago
- An in-place file rewrite utility, useful for redirecting output to same file as source.☆26Mar 3, 2021Updated 5 years ago
- Fabric port of Mystical Agriculture☆10May 17, 2024Updated 2 years ago
- Rust raise file limit☆27Nov 28, 2023Updated 2 years ago