Extremely flexible golang deep comparison, extends the go testing package, tests HTTP APIs and provides tests suite
☆464Sep 17, 2026Updated last month
Alternatives and similar repositories for go-testdeep
Users that are interested in go-testdeep are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Golang errors with stack trace and source fragments.☆1,127Apr 2, 2026Updated 6 months ago
- Define and run pattern-based custom linting rules.☆882Sep 25, 2025Updated last year
- Generic batches for go☆13Dec 5, 2021Updated 4 years ago
- Test your code without writing mocks with ephemeral Docker containers 📦 Setup popular services with just a couple lines of code ⏱️ No ba…☆1,487Apr 13, 2026Updated 6 months ago
- GoWrap is a command line tool for generating decorators for Go interfaces☆1,339Oct 21, 2026Updated last week
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Gadgeto! is a collection of tools that aim to facilitate the development of REST APIs in Go.☆64Feb 25, 2026Updated 8 months ago
- A collection of packages to augment the go testing package and support common patterns.☆576Sep 14, 2026Updated last month
- Go error library with error portability over the network☆2,479Oct 19, 2026Updated last week
- ☆30Oct 15, 2020Updated 6 years ago
- A Go (golang) package for representing a list of errors as a single error.☆2,591Oct 14, 2026Updated 2 weeks ago
- Crash your app in style (Golang)☆3,707Oct 19, 2026Updated last week
- Package for comparing Go values in tests☆4,681Jun 18, 2026Updated 4 months ago
- OAuth2 client in Go☆22Mar 5, 2024Updated 2 years ago
- 👩⚕️👨⚕️ Mission-critical concurrent health checks synchronization☆31Jul 7, 2026Updated 3 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Refactoring and code transformation tool for Go.☆1,040Feb 11, 2025Updated last year
- Error handling library with readable stack traces and flexible formatting support 🎆☆1,796Apr 3, 2025Updated last year
- Go linter to detect erroneous multiplication of duration values☆47Oct 24, 2025Updated last year
- Write better integration tests! Dockertest helps you boot up ephermal docker images for your Go tests with minimal work.☆4,527Oct 23, 2026Updated last week
- Hedged HTTP client which helps to reduce tail latency at scale.☆134Aug 13, 2024Updated 2 years ago
- 🍕 Enjoy a slice! A utility library for dealing with slices and maps that focuses on type safety and performance.☆2,033Dec 22, 2025Updated 10 months ago
- OVH Logs Data Platform - Tail CLI tooling☆28Mar 9, 2025Updated last year
- Idiomatic Go input parsing with subcommands, positional values, and flags at any position. No required project or package layout and no e…☆955Jul 29, 2026Updated 3 months ago
- Mergo: merging Go structs and maps since 2013☆3,108Oct 12, 2026Updated 2 weeks ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Building event-driven applications the easy way in Go.☆9,931Updated this week
- Minimalist and zero-dependency scheduling library for Go☆2,018Jan 20, 2026Updated 9 months ago
- Powerful mock generation tool for Go programming language☆752Oct 21, 2026Updated last week
- Visualise Go runtime metrics in real time☆3,647Oct 21, 2026Updated last week
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Go Dependency Analysis toolkit☆1,731Oct 13, 2026Updated 2 weeks ago
- 🔥 Fast, strict, configurable, extensible, and beautiful linter for Go☆5,559Updated this week
- HTTP mocking for Golang☆2,078Oct 6, 2026Updated 3 weeks ago
- A better ORM for Go, based on non-empty interfaces and code generation.☆1,454Oct 19, 2026Updated last week
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- 'go test' runner with output optimized for humans, JUnit XML for CI integration, and a summary of the test results.☆2,735Apr 15, 2026Updated 6 months ago
- A stricter gofmt☆4,103Oct 12, 2026Updated 2 weeks ago
- Ruby on Rails like test fixtures for Go. Write tests against a real database☆1,240Oct 21, 2026Updated last week
- Better structured concurrency for go☆10,434Sep 1, 2026Updated last month
- Staticcheck - The advanced Go linter☆6,921Updated this week
- Syntax-aware Go code search, based on the mvdan/gogrep☆47Apr 19, 2023Updated 3 years ago
- Testcontainers for Go is a Go package that makes it simple to create and clean up container-based dependencies for automated integration/…☆5,019Updated this week