S/Kademlia in Go. Heavy WIP.
☆11Jun 30, 2020Updated 6 years ago
Alternatives and similar repositories for kademlia-go
Users that are interested in kademlia-go are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- The bare minimum for high performance, fully-encrypted bidirectional RPC over TCP in Go with zero memory allocations.☆120Jun 22, 2020Updated 6 years ago
- Kademlia based p2p network.☆12Feb 21, 2022Updated 4 years ago
- ☆13Sep 17, 2024Updated 2 years ago
- Golang based hack to experiment the uses of IPLD through the IPFS DAG operations using the go-ipfs-api package.☆11Jun 13, 2020Updated 6 years ago
- VWBL SDK for JavaScript in the browser and Node.js☆16Mar 17, 2025Updated last year
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- A tool collection about BitTorrent.☆13Mar 4, 2023Updated 3 years ago
- 🦀 CrabFS is an embeddable seekable distributed (p2p) block storage☆15Mar 20, 2023Updated 3 years ago
- A reliability layer for UDP connections in Go.☆141May 31, 2020Updated 6 years ago
- a (currently toy) implementation of the various consensus algorithms discussed in the Avalanche paper.☆17Jun 29, 2018Updated 8 years ago
- Oasys Optimism Client for Verse operators.☆15Jul 12, 2024Updated 2 years ago
- Quickly build microservices using p2p networking in NodeJS/Go.☆654Mar 26, 2022Updated 4 years ago
- GAME Hub is a fair and secure game-specific blockchain using tendermint where developers can easily create decentralized games.☆16Jun 3, 2022Updated 4 years ago
- Template for Ethereum DApps. Truffle + React + Typescript☆14Dec 12, 2022Updated 3 years ago
- Userland linux/amd64emulator in Go☆18Nov 27, 2020Updated 5 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- The New Pact☆25Oct 20, 2025Updated last year
- ☆20Jun 21, 2018Updated 8 years ago
- Solidity学習用のリポジトリ☆16Aug 4, 2024Updated 2 years ago
- NIST P-256 Elliptic Curve Cryptography for Node and the Browsers☆23Oct 11, 2018Updated 8 years ago
- A library for executing search queries, retrieving metadata, and obtaining direct links to video-only/audio-only/muxed versions of videos…☆76Dec 13, 2020Updated 5 years ago
- A Go implementation of the Cassowary constraint solving algorithm.☆80May 31, 2020Updated 6 years ago
- A command-line utility that downloads file/files shared over a BitTorrent-network. The application joins a network of peers, and concurre…☆17Jul 2, 2025Updated last year
- RPC over libp2p pubsub with error handling☆12Mar 15, 2023Updated 3 years ago
- Message-Based P2P Networking Library☆32Nov 18, 2024Updated last year
- Open source password manager - Proton Pass • AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- A small, fast, cross-platform, async Zig networking framework built on top of lithdew/pike.☆41Nov 19, 2022Updated 3 years ago
- An open source 3d slide presentation for the Godot Engine☆11Aug 3, 2017Updated 9 years ago
- TemporalX gRPC and Documentation Resources☆13Apr 11, 2023Updated 3 years ago
- An MCP proxy which is Tailscale aware☆15Jun 9, 2025Updated last year
- ☁️🔔 webpush notification support for ntfy☆14Jan 7, 2023Updated 3 years ago
- A very easy-to-use wrapper of Duktape JavaScript engine, including wrappers for C, Go and Java. The bridge wrapper is also supporting mo…☆14Dec 20, 2021Updated 4 years ago
- The Ara FileSystem☆10May 3, 2021Updated 5 years ago
- a libp2p-backed daemon wrapping the functionalities of go-libp2p for use in other languages☆12Feb 9, 2025Updated last year
- NUR - https://github.com/nix-community/NUR☆13Mar 23, 2026Updated 7 months ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- rustdoc 手册 中文版————Chinese translation of The rustdoc Book☆14Jun 15, 2024Updated 2 years ago
- ☆12Dec 30, 2025Updated 10 months ago
- Fork of cannon that supports Rust☆15Sep 24, 2022Updated 4 years ago
- [ARCHIVED] config is now part of go-ipfs repo☆16Mar 9, 2022Updated 4 years ago
- About A simple native Rust Escrow program.☆11Oct 6, 2024Updated 2 years ago
- A tool for easier dependency injection.☆10Sep 4, 2023Updated 3 years ago
- 📧 Implemented Keys, Algorithms (RFC9053), COSE (RFC9052) and CWT (RFC8392) in Go.☆24Sep 1, 2026Updated 2 months ago