Lossy PNG compressor for RGBA PNGs. Has two modes: lossy averaging filter (blurizer) that denoises the image and optimal posterization using Median Cut quantization to reduce number of unique colors in the image with minimal visual distortion
☆254Feb 26, 2023Updated 3 years ago
Alternatives and similar repositories for mediancut-posterizer
Users that are interested in mediancut-posterizer are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Lossy compression of PNG images☆92Nov 25, 2020Updated 5 years ago
- Improved JPEG encoder.☆21Oct 14, 2023Updated 3 years ago
- Image similarity comparison simulating human perception (multiscale SSIM in Rust)☆1,207Oct 1, 2026Updated last month
- A Bash script to automate adaptive JPEG compression using common CLI tools☆377Nov 1, 2019Updated 7 years ago
- Palette quantization library that powers pngquant and other PNG optimizers☆938Jun 21, 2026Updated 4 months ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- simple crusher tries to reduce FLIFs in size by recompressing them with different parameters☆13May 9, 2017Updated 9 years ago
- Improved JPEG encoder.☆5,744Jun 23, 2025Updated last year
- `pngwolf` uses a genetic algorithm to find PNG scanline filter combinations that compress well☆55Feb 10, 2022Updated 4 years ago
- A collection of recompression utilities for your .ZIP archives, .PNG snapshots, .MNG video clips and .GZ files☆255Jul 16, 2025Updated last year
- ☆100Dec 8, 2025Updated 11 months ago
- JPEGrescan: losslessly shrink any JPEG file - YOU PROBABLY SHOULD USE MozJPEG https://github.com/mozilla/mozjpeg☆187Mar 27, 2019Updated 7 years ago
- DjVu encoder with foreground/background separation☆16Jun 23, 2026Updated 4 months ago
- A cross-platform tool for optimizing PNG and JPG files.☆736Mar 10, 2021Updated 5 years ago
- ☆46Feb 17, 2023Updated 3 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Research JPEG encoder☆195Jun 9, 2018Updated 8 years ago
- C++ implementation of Bjontegaard Delta SNR and Delta Rate metric☆11Nov 16, 2022Updated 3 years ago
- 基于远程过程调试协议的性能分析工具☆11Dec 23, 2014Updated 11 years ago
- Utility that tries to figure out if you are on cellular or broadband☆11Sep 29, 2015Updated 11 years ago
- Makes the algorithms and APIs defined by URL Standard (replaces RFC 3986 and RFC 3987) available on PHP. / URL Standard (RFC 3986、RFC 398…☆14Jan 28, 2026Updated 9 months ago
- A robust & optimized ES3-compatible polyfill for the `Array.of` method in ECMAScript 6.☆16Sep 5, 2024Updated 2 years ago
- A single and multi-scale SSIM implementation in C++☆11Mar 26, 2025Updated last year
- A super light weight FPS counter w/ Jank Vision™☆13Oct 29, 2013Updated 13 years ago
- ☆13Mar 27, 2013Updated 13 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Browser extension for Chrome and Firefox. Mirror from https://gerrit.wikimedia.org/g/performance/WikimediaDebug/.☆16Updated this week
- A Bandwidth tester in Javascript... but please use boomerang instead, I'm moving development there☆12Jun 27, 2010Updated 16 years ago
- This package contains source code for special JPEG decompression and recompression routines, which may help developers as a framework in…☆15Jan 20, 2016Updated 10 years ago
- SQZ - Low complexity, scalable lossless and lossy image compression library☆23Jan 8, 2024Updated 2 years ago
- Demo of a fast PNG encoder.☆116Oct 9, 2025Updated last year
- Fast JavaScript implementation of bCrypt☆14Jul 5, 2017Updated 9 years ago
- Demonstration framework for displaying the benefits of progressive jpeg images☆26Feb 25, 2016Updated 10 years ago
- See how a module is used in npm.☆20Apr 15, 2023Updated 3 years ago
- SimpleJPEG: simple jpeg encoder☆87Updated this week
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A growing collection of Grunt snippets for Sublime Text 2/3☆15Apr 21, 2014Updated 12 years ago
- `pngwolf` uses a genetic algorithm to find PNG scanline filter combinations that compress well☆112Jan 7, 2012Updated 14 years ago
- J40: Independent, self-contained JPEG XL decoder☆239Updated this week
- Advanced Zopfli fork: ZIP support, multi-threading, compression cache (zopfliDB), auto/manual block split, compression and speed control …☆88Jun 21, 2025Updated last year
- ☆20Aug 10, 2022Updated 4 years ago
- This repository has been retired. Please see the readme below for more information.☆29Aug 31, 2022Updated 4 years ago
- Merged into Gifsicle!☆982May 27, 2019Updated 7 years ago