An auxiliary serde library providing helpful functions for serialisation and deserialisation for containers, struct fields and others.
☆172Sep 21, 2025Updated last year
Alternatives and similar repositories for serde-aux
Users that are interested in serde-aux are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- This crate provides custom de/serialization helpers to use in combination with serde's `with`-annotation and with the improved `serde_as`…☆865Updated this week
- Custom deserialization for fields that can be specified as multiple types.☆20Jan 25, 2025Updated last year
- Diesel support for citext extension☆11Aug 17, 2020Updated 6 years ago
- x-www-form-urlencoded meets Serde☆265Aug 13, 2024Updated 2 years ago
- Some more derive(Trait) options☆2,150Sep 7, 2026Updated last month
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- A small rust library for adding custom derives to enums☆2,462Mar 7, 2026Updated 7 months ago
- Dynamic transformation of data using serde serializable, deserialize using JSON and a JSON transformation syntax similar to Javascript JS…☆16Oct 24, 2021Updated 4 years ago
- Simple validation for Rust structs☆2,522Jul 27, 2026Updated 2 months ago
- xml-rs based deserializer for Serde (compatible with 1.0+)☆333Feb 5, 2026Updated 8 months ago
- Serialization value trees☆49Jul 31, 2024Updated 2 years ago
- A Minecraft clone built with wgpu and Rust☆22Aug 21, 2024Updated 2 years ago
- A collection of open source Rust crates from iqlusion☆579Updated this week
- Easy code duplicate with substitution for Rust☆254May 21, 2026Updated 4 months ago
- This crate offers procedural macros designed to facilitate the swift implementation of Rust's built-in traits.☆165Sep 14, 2026Updated last month
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- oh heck, a case conversion library☆603Aug 9, 2025Updated last year
- ☆61Jan 20, 2026Updated 8 months ago
- A parser and formatter for std::{SystemTime, Duration}☆398Oct 7, 2026Updated last week
- Rust library for working with data from Wikidata.☆16Sep 6, 2026Updated last month
- A set of alternative `derive` attributes for Rust☆466Sep 27, 2025Updated last year
- Wrapper around reqwest to allow for client middleware chains.☆382May 19, 2026Updated 4 months ago
- Find unused dependencies in Cargo.toml☆2,140Apr 29, 2026Updated 5 months ago
- Generate JSON Schema documents from Rust code☆1,419Updated this week
- An implementation of RFC6265☆31Feb 16, 2026Updated 8 months ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Cargo subcommand to provide various options useful for testing and continuous integration.☆874Oct 10, 2026Updated last week
- HTTP mocking for Rust!☆783Aug 1, 2026Updated 2 months ago
- Rust cache structures and easy function memoization☆2,097Updated this week
- ☝️send desktop notifications from your Rust app.☆1,426Oct 7, 2026Updated last week
- Rust Job Queue using Postgres and TMQ☆38Jun 26, 2020Updated 6 years ago
- Find out path at which a deserialization error occurred☆427Jun 24, 2026Updated 3 months ago
- A library for SSH key based (agents or static files) authentication tokens☆29Aug 31, 2026Updated last month
- Tool to mass-rename S3 keys☆21Oct 28, 2020Updated 5 years ago
- Rust library for retrieving and interacting with the crates.io index☆74Sep 3, 2026Updated last month
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- A powerful mock object library for Rust☆1,849Oct 8, 2026Updated last week
- RFC 6902 (JSON Patch) / RFC 7396 (JSON Merge Patch) implementation for Rust☆183Apr 30, 2026Updated 5 months ago
- Async, lock-free synchronization primitives for task wakeup☆53Sep 8, 2024Updated 2 years ago
- Serde serializable and deserializable trait objects☆1,550Aug 3, 2026Updated 2 months ago
- Rust OpenAPI 3.0 docs generator☆36Apr 5, 2023Updated 3 years ago
- Rust crate to get the IANA time zone for the current system☆52Apr 29, 2026Updated 5 months ago
- Adaptors between compression crates and Rust's async IO types☆671Updated this week