Encode and decode CBOR documents, with both easy mode, streaming mode, and SAX-style evented mode.
☆379Mar 22, 2026Updated 6 months ago
Alternatives and similar repositories for node-cbor
Users that are interested in node-cbor are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- The Concise Binary Object Representation (CBOR) data format (RFC7049) implemented in pure JavaScript.☆340Jun 7, 2019Updated 7 years ago
- Ultra-fast CBOR encoder/decoder with extensions for records and structural cloning☆397Sep 24, 2026Updated 2 weeks ago
- Assimilate your JavaScript objects into cbor☆30Apr 27, 2021Updated 5 years ago
- JavaScript implementation of the IPLD dag-cbor format.☆54Aug 11, 2021Updated 5 years ago
- Sodium signatures that works in node and in the browser☆33Jan 20, 2018Updated 8 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- PoC: A rusty Option for TypeScript.☆21Feb 12, 2025Updated last year
- A msgpack v5 implementation for node.js, with extension points / msgpack.org[Node]☆500Sep 26, 2026Updated 2 weeks ago
- Fast CBOR focusing on strictness and determinism☆66Oct 1, 2026Updated last week
- JavaScript implementation of multistream-select☆29Oct 18, 2022Updated 3 years ago
- JSY is an indented (offside) JavaScript dialect. We believe indentation is better at describing code blocks.☆10Jan 2, 2026Updated 9 months ago
- IIIF annotations JS client on top of IPFS☆12May 1, 2025Updated last year
- CID implementation in JavaScript☆98Sep 2, 2021Updated 5 years ago
- JavaScript implementation of COSE☆27Sep 7, 2026Updated last month
- This is a implementation of a RFC 8941: Structured Field Values for HTTP in JavaScript.☆17Oct 20, 2025Updated 11 months ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- TypeScript implementation of the CBOR specification☆23Feb 10, 2023Updated 3 years ago
- Hyperdrive is a secure, real time distributed file system☆2,023Sep 17, 2026Updated 3 weeks ago
- Sodium encryption that works in node and in the browser☆47Feb 17, 2017Updated 9 years ago
- Single, mutable sources of truth for your CLIs☆17Nov 1, 2019Updated 6 years ago
- Modern and pretty alternative of npm-run-all☆13Jun 19, 2026Updated 3 months ago
- Make sure the last sync call to an async function is executed after all previous ones have finished☆31Jan 30, 2016Updated 10 years ago
- Concise data definition language (RFC 8610) implementation and JSON validator in Node.js☆22Mar 27, 2026Updated 6 months ago
- no-bullshit url shortening with node.js☆10Jan 11, 2023Updated 3 years ago
- Flattens the underlying C structures of a concatenated JavaScript string☆387Jan 30, 2022Updated 4 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- An 100% spec compliant ES2021 JavaScript parser written in JS☆510Aug 16, 2026Updated last month
- A simplified FinalizationRegistry utility that works.☆20Aug 1, 2024Updated 2 years ago
- An iteration of the Node.js core streams with a series of improvements.☆239Aug 25, 2026Updated last month
- Create a noop process and get the PID☆14Aug 10, 2021Updated 5 years ago
- Convert a string/promise/array/iterable/asynciterable/buffer/typedarray/arraybuffer/object into a stream☆212Sep 18, 2026Updated 3 weeks ago
- Web Authentication for Node.js applications☆23Feb 21, 2024Updated 2 years ago
- Proposal to add a `stride` parameter to TypedArrays☆27Mar 17, 2020Updated 6 years ago
- A TypeScript-like language for WebAssembly.☆18,031Sep 14, 2026Updated 3 weeks ago
- Polyfill of Node.js awaitable timers☆23Mar 17, 2021Updated 5 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A tool to downgrade your yarn.lock☆13Jul 20, 2026Updated 2 months ago
- node.js child_process.spawn mocking library☆18May 6, 2024Updated 2 years ago
- Get an available TCP port☆928Sep 18, 2026Updated 3 weeks ago
- A node.js module to make the use of promises safe☆663Dec 21, 2024Updated last year
- Javascript plugin for Capnproto☆49Nov 10, 2019Updated 6 years ago
- A proposal defining standard identifier keys for various runtime environments☆46May 28, 2026Updated 4 months ago
- A crazy fast HTTP router☆1,631Updated this week