rust interface to libzfs(_core) and related interfaces
☆18Mar 10, 2023Updated 3 years ago
Alternatives and similar repositories for rust-libzfs
Users that are interested in rust-libzfs are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Bindings to libzfs from rust☆27Jul 11, 2023Updated 3 years ago
- Stable interface for programmatic administration of ZFS from Rust☆76Feb 23, 2026Updated 8 months ago
- A wrapper around openat, symlinkat, and similar system calls☆22Dec 12, 2023Updated 2 years ago
- OCaml bindings to libqfs☆13Nov 7, 2025Updated 11 months ago
- Xen event channel interface for Mirage☆10Mar 6, 2025Updated last year
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- ☆11Apr 22, 2016Updated 10 years ago
- Rust APIs for userworld zfs(uzfs)☆23Updated this week
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- A rpc client library for the Transmission bittorrent client written in OCaml.☆10Jan 27, 2018Updated 8 years ago
- Ocaml NBD library☆14Oct 13, 2026Updated 2 weeks ago
- ☆15Dec 16, 2014Updated 11 years ago
- NATed networking on MacOS X using the vmnet framework☆18May 31, 2025Updated last year
- MirageOS IRC daemon.☆14Feb 16, 2018Updated 8 years ago
- OCaml features we want really bad☆11Oct 6, 2011Updated 15 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Bindings for hypervisor sockets, for Linux, Windows and macOS (via Hyperkit)☆18Aug 24, 2025Updated last year
- Type-classes for mirage applications☆12Oct 3, 2016Updated 10 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- POSIX sendmsg bindings for OCaml☆16Nov 5, 2016Updated 9 years ago
- Pure OCaml code for parsing, printing, modifying .qcow format data☆21Jul 22, 2026Updated 3 months ago
- telnet protocol in OCaml☆15Nov 15, 2016Updated 9 years ago
- Transactions, Keys, and Values☆21Nov 3, 2017Updated 8 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Membership protocol for Mirage unikernel clusters based on SWIM☆18Mar 14, 2016Updated 10 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- Mergeable queues☆19Mar 24, 2015Updated 11 years ago
- Copy-on-write NFS server☆15Aug 17, 2009Updated 17 years ago
- imaplet revamp with Lwt☆18Aug 9, 2017Updated 9 years ago
- OCaml interface to cgroups☆22Sep 16, 2022Updated 4 years ago
- OCaml bindings for jech/dht☆25Jun 16, 2020Updated 6 years ago
- Collect profiling information☆18Mar 9, 2023Updated 3 years ago
- Library to provide session types to allow for static verification of protocols between concurrent computations.☆17Jan 1, 2017Updated 9 years ago
- An ocaml library for using BPF/AF_SOCKET in a platform independent way.☆17Jul 24, 2023Updated 3 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- `macosx.internal` -> `macosx`☆15Oct 19, 2026Updated last week
- rsync as you edit☆14Feb 6, 2023Updated 3 years ago
- ChaCha20, ChaCha12 and ChaCha8 encryption functions, in OCaml☆10Apr 3, 2022Updated 4 years ago
- Easy process control in OCaml☆18Mar 23, 2023Updated 3 years ago
- A variety of content chunking algorithms with a common API in rust☆18Jun 18, 2023Updated 3 years ago
- Collection of tools related to 7z, stego, and CTFs☆15Oct 9, 2020Updated 6 years ago