⏯ Dumb and (re)useful React components for media players.
☆194Mar 26, 2023Updated 3 years ago
Alternatives and similar repositories for react-player-controls
Users that are interested in react-player-controls are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- create simple, beautifully animated grid-based layouts using react☆16Aug 7, 2017Updated 9 years ago
- 🏄🏻 **MOVED** Element resize sensor with optional debounce☆10Oct 24, 2019Updated 7 years ago
- A React component for playing a variety of URLs, including file paths, YouTube, Facebook, Twitch, SoundCloud, Streamable, Vimeo, Wistia a…☆10,293Oct 3, 2026Updated last month
- A beautiful fully customizable React + Redux notification system built with styled-components☆29Dec 24, 2018Updated 7 years ago
- localForage engine for redux-storage☆10Jan 27, 2018Updated 8 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- A collection of Codemods written with JSCodeshift that will help update our old, crusty JavaScript to nice, clean JavaScript.☆12Mar 7, 2018Updated 8 years ago
- ☆10Apr 25, 2018Updated 8 years ago
- Animate stacks with great performances☆16Oct 14, 2017Updated 9 years ago
- Better inspect formatting, using prettier for arrays, objects and functions, and util.inspect for everything else.☆13Dec 2, 2017Updated 8 years ago
- Accessible autocompletion widgets, implemented in React.☆19Mar 31, 2016Updated 10 years ago
- A React component to zoom images on hover https://react-img-zoom.netlify.com/☆119Aug 1, 2023Updated 3 years ago
- 🥁React suspense, the sexy way☆18Aug 11, 2021Updated 5 years ago
- React video player for TypeScript and JavaScript like youtube☆10Sep 4, 2021Updated 5 years ago
- Simple to use React Hook with click outside functionality☆10Apr 15, 2026Updated 6 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- A simple React wrapper on the HTML5 audio tag☆600Nov 12, 2023Updated 2 years ago
- Customizable positioning for tooltips, menus, and any other DOM elements inside of a container☆14Feb 11, 2018Updated 8 years ago
- A smart popover component with animation support for ReactJS☆195Jan 7, 2023Updated 3 years ago
- Production ready Wordpress theme built with React, Redux, Redux-Thunk, Intl, React Router v4, etc... and packaged by Webpack 2. Enjoy!☆12Mar 1, 2018Updated 8 years ago
- Seek slider for a video player like YouTube.☆43Sep 25, 2025Updated last year
- A tiny (no dependency) library for click / touch and hold functionality!☆18Jan 15, 2017Updated 9 years ago
- A customizeable HTML5 Video React component with i18n and a11y.☆454Dec 12, 2023Updated 2 years ago
- React component to fetch image resources via web workers 🤖🤖☆231Jun 22, 2018Updated 8 years ago
- 📼 A flexible media player component library for React that requires no up-front config☆187Mar 5, 2023Updated 3 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- 📻 Create custom web audio players with React☆1,451Jan 5, 2023Updated 3 years ago
- A React component for intelligently truncating text in the middle of the string.☆29Mar 4, 2023Updated 3 years ago
- A powerful and flexible React tooltip and menu library.☆142Feb 2, 2022Updated 4 years ago
- Connect a Web Audio API AudioNode and stream out the realtime RMS audio level.☆27Jan 4, 2016Updated 10 years ago
- ES6-Based Unit Testing☆60Mar 3, 2019Updated 7 years ago
- Trace functions in EcmaScript Modules☆13Dec 4, 2025Updated 10 months ago
- A fancy immutable storage library for JavaScript☆164May 8, 2021Updated 5 years ago
- Small React state container running inside WebWorker☆31Jan 29, 2018Updated 8 years ago
- ClickOutside component for React.☆768Dec 22, 2020Updated 5 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Create breakpoints to your component props☆61Sep 23, 2017Updated 9 years ago
- A way to quickly add a Grid Layout to your React app 🚀☆183Dec 11, 2022Updated 3 years ago
- An HTML experiment for generating randomly created CSS3 gradients (both linear and radial)☆12Sep 5, 2018Updated 8 years ago
- RFC-3986 URI toolkit for Node.js. IDN (RFC-3987), IPv6 zone identifiers (RFC 6874), Sitemap protocol. Zero dependencies.☆16Updated this week
- Service-oriented state management for React☆12Jun 30, 2022Updated 4 years ago
- Browser API's turned into declarative React components and HoC's☆3,701Jan 24, 2023Updated 3 years ago
- A higher order component for loading components with promises.☆16,494Jul 10, 2024Updated 2 years ago