Lean and mean Javascript implementation of the JSON-Patch standard (RFC 6902). Update JSON documents using delta patches.
☆1,983Oct 28, 2026Updated this week
Alternatives and similar repositories for JSON-Patch
Users that are interested in JSON-Patch are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- JSON Patch and diff based on rfc6902☆641Aug 11, 2024Updated 2 years ago
- Diff & patch JavaScript objects☆5,353Updated this week
- An implementation of the JSONPatch (and JSONPointer) IETF RFCs for Javascript (Node.JS and the Browser)☆261Jul 22, 2024Updated 2 years ago
- Complete implementation of RFC6902 in TypeScript☆380Updated this week
- A JavaScript implementation of the JSON Media Type for partial modifications: http://tools.ietf.org/html/rfc6902☆179Aug 21, 2017Updated 9 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- JSON toolkit for JavaScript.☆106Feb 11, 2023Updated 3 years ago
- The fastest JSON schema Validator. Supports JSON Schema draft-04/06/07/2019-09/2020-12 and JSON Type Definition (RFC8927)☆14,868Sep 6, 2026Updated last month
- json-joy is a library that implements cutting-edge real-time and collaborative editing algorithms and utilities for JSON data models, wit…☆1,100Sep 8, 2026Updated last month
- A JSON-like data structure (a CRDT) that can be modified concurrently by different users, and merged again automatically.☆14,684Mar 14, 2023Updated 3 years ago
- Create the next immutable state by mutating the current one☆29,000Updated this week
- An implementation of the JSON Merge Patch (RFC 7396)☆90Feb 10, 2024Updated 2 years ago
- Shared data types for building collaborative software☆23,021Updated this week
- Lerna is a fast, modern build system for managing and publishing multiple JavaScript/TypeScript packages from the same repository.☆36,041Updated this week
- Comlink makes WebWorkers enjoyable.☆12,805Updated this week
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- State machines, statecharts, and actors for complex logic☆30,404Updated this week
- Generate json-schema from your Typescript sources☆3,267Jul 14, 2026Updated 3 months ago
- A JavaScript codemod toolkit.☆10,042Oct 27, 2026Updated last week
- Realtime database backend based on Operational Transformation (OT)☆6,562Updated this week
- A tiny JavaScript debugging utility modelled after Node.js core's debugging technique. Works in Node.js and web browsers☆11,457Oct 14, 2026Updated 2 weeks ago
- Normalizes nested JSON according to a schema☆20,777Mar 19, 2022Updated 4 years ago
- Primus, the creator god of the transformers & an abstraction layer for real-time to prevent module lock-in.☆4,465Nov 6, 2023Updated 2 years ago
- The most powerful data validation library for JS☆21,164Oct 28, 2026Updated last week
- 💾 Offline storage, improved. Wraps IndexedDB, WebSQL, or localStorage using a simple but powerful API.☆25,804Jul 30, 2024Updated 2 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- A tiny (118 bytes), secure, URL-friendly, unique string ID generator for JavaScript☆27,119Oct 16, 2026Updated 2 weeks ago
- Practical functional Javascript☆24,055Oct 12, 2026Updated 3 weeks ago
- Next-generation ES module bundler☆26,300Updated this week
- Node.js test runner that lets you develop with confidence 🚀☆20,827Updated this week
- JavaScript syntax tree transformer, nondestructive pretty-printer, and automatic source map generator☆5,257Oct 18, 2026Updated 2 weeks ago
- Bluebird is a full featured promise library with unmatched performance.☆20,466Nov 7, 2024Updated last year
- A javascript text differencing implementation.☆9,221Updated this week
- Package your Node.js project into an executable☆24,310Jan 3, 2024Updated 2 years ago
- JSON Schema Type Builder with Static Type Resolution for TypeScript☆7,024Updated this week
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Immutable persistent data collections for Javascript which increase efficiency and simplicity.☆33,019Updated this week
- Minimal and efficient cross-platform file watching library☆12,264Oct 27, 2026Updated last week
- An extremely fast, React-like JavaScript library for building modern user interfaces☆16,459Updated this week
- The local-first database that runs on every JS runtime and replicates with your existing backend - no vendor, no lock-in - https://rxdb.i…☆23,424Updated this week
- The Reactive Extensions for JavaScript☆19,316Apr 18, 2018Updated 8 years ago
- High performance Node.js image processing, the fastest module to resize JPEG, PNG, WebP, AVIF and TIFF images. Uses the libvips library.☆32,819Updated this week
- - PouchDB is a pocket-sized database.☆17,624Updated this week