Public key cryptography library for Ruby providing the X25519 Diffie-Hellman function
☆49Jan 22, 2026Updated 9 months ago
Alternatives and similar repositories for x25519
Users that are interested in x25519 are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Ruby implementation of Miscreant: misuse-resistant encryption library with AES-SIV (RFC 5297) and AES-PMAC-SIV support☆22Feb 1, 2021Updated 5 years ago
- Ed25519 high-performance public-key signature system as a RubyGem (MRI C extension and JRuby Java extension)☆136Sep 4, 2026Updated last month
- Elliptic curves Rust reference implementation☆16Mar 10, 2024Updated 2 years ago
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Proof-of-concept implementation of the (V)OPRF protocol in https://datatracker.ietf.org/doc/draft-irtf-cfrg-voprf/☆23Aug 24, 2020Updated 6 years ago
- (Work in progress) High-assurance FrodoKEM-640-SHAKE through Jasmin and EasyCrypt.☆14Jan 28, 2022Updated 4 years ago
- [RFC9380] Hash to curves - Go reference implementation☆21Jul 10, 2026Updated 3 months ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- Fast 4 way vectorized ladder for the complete set of Montgomery curves☆11Feb 13, 2019Updated 7 years ago
- Seasonal-trend decomposition for Ruby☆21Aug 8, 2026Updated 2 months ago
- ☆27Nov 21, 2021Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Solution to harden TLS security by storing private keys and delegating operations to the Trused Execution Environment☆13Oct 10, 2022Updated 4 years ago
- A multipart parser written in Ruby☆17Jan 27, 2018Updated 8 years ago
- jemal gem – Ruby interface to jemalloc☆28Apr 14, 2017Updated 9 years ago
- A pure-Ruby implementation of systemd's sd_notify(3)☆53Oct 26, 2025Updated last year
- ☆11Mar 19, 2023Updated 3 years ago
- Golang Post Quantum Secure Wire☆19Jul 31, 2025Updated last year
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- A small and easy to use HPKE implementation in Go.☆20Sep 17, 2026Updated last month
- A pure rust implementation of Arcturus proofs for confidential transactions.☆12Sep 28, 2025Updated last year
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- ☆17Sep 27, 2026Updated last month
- The secure messaging summit information☆20Oct 27, 2020Updated 6 years ago
- git post-receive hook for running r10k via gitolite3☆10Oct 25, 2013Updated 13 years ago
- A wrapper around Coin-Or Cbc Integer Linear Programming solver☆28Sep 20, 2022Updated 4 years ago
- Models for authenticated key exchange in Tamarin☆12Oct 9, 2019Updated 7 years ago
- An implementation of a post quantum anonymous credential scheme☆17Dec 18, 2024Updated last year
- ☆30Jun 18, 2026Updated 4 months ago
- A Puppet module to manage MCollective☆17Oct 18, 2026Updated last week
- ☆17Aug 2, 2021Updated 5 years ago
- Proton VPN Special Offer - Get 70% off • AdSpecial partner offer. Trusted by over 100 million users worldwide. Tested, Approved and Recommended by Experts.
- Authenticated Encryption with Associated Data☆26May 21, 2026Updated 5 months ago
- Event Store support for Ruby Object Mapper☆10Feb 10, 2016Updated 10 years ago
- ☆38Updated this week
- Protochannel is a TicTacToe game using of Ethereum State Channel to do off-chain transactions☆10Dec 29, 2022Updated 3 years ago
- ☆18Jul 11, 2025Updated last year
- ☆46Apr 23, 2026Updated 6 months ago
- Reference implementations of post-quantum cryptographic primitives☆32Feb 16, 2026Updated 8 months ago